[bug ?] Forced purchase after resuming a save

Discuss problems related to FTL here. If you are having a problem or experiencing a bug PLEASE READ THE "MUST READ" POST.
Néocray
Posts: 4
Joined: Thu Feb 14, 2013 4:44 pm

[bug ?] Forced purchase after resuming a save

Postby Néocray » Tue Dec 16, 2014 2:32 pm

Hi,

I'm facing what seems a bug.
I jumped to a store beacon, bought a weapon, then save/quit.
When I resumed my game, it showed this : a message introducing the store, AND a 55-scrap debit for buying a slug crewman with piloting skill mastered.
When the store is open, the 3 screwmen in stock are still here, so it doesn't come from here.

I've been able to recover the continue.sav file, and it is 100% reproductible, if someone want to try...
r543
Posts: 44
Joined: Tue Apr 08, 2014 5:19 pm

Re: [bug ?] Forced purchase after resuming a save

Postby r543 » Tue Dec 16, 2014 6:46 pm

That Slug and the name of it can only mean one thing:

The game glitched up the events with this:
http://ftl.wikia.com/wiki/Slocknog

This is a special event where a special Slug called Slocknog can be bought. For some reason it ended up with the first option of the player buying slocknog.
Néocray
Posts: 4
Joined: Thu Feb 14, 2013 4:44 pm

Re: [bug ?] Forced purchase after resuming a save

Postby Néocray » Wed Dec 17, 2014 1:33 pm

You're right. I didn't make the connection, now it makes sense.

Is this a known glitch?
Ray Robertson
Posts: 39
Joined: Thu Jul 24, 2014 7:58 am

Re: [bug ?] Forced purchase after resuming a save

Postby Ray Robertson » Wed Dec 17, 2014 5:25 pm

I had something happen which I think might be related. It was that nebula event where you find some stuff and then get boarded too. Anyway, I killed all the boarders and then save&quit. The next day I Continued and this happened: http://cloud-4.steampowered.com/ugc/547 ... 2044898A8/, without the boarders though. Note the "Plasma Storm" effect taking place again, as if you just jumped to the beacon (flak still charged even) and FTL charged up.

I did not save&quit again to check whether it would happen over and over, that would have been exploiting a bug. ;)

I also took a screenshot of the sector and beacon it happened at, if that helps: http://cloud-4.steampowered.com/ugc/547 ... 6E0770B33/

Who is online

Users browsing this forum: No registered users and 11 guests