Page 36 of 46

Re: [TOOL]FTLEdit: FTL Ship editor [v0.91 18th Dec] Open sou

Posted: Mon Jan 07, 2013 4:57 pm
by Disc10
*blows dust off account*

Hey there, I have what is probably a dumb question for you guys. I'm trying to edit the Zoltan Ship to have three human crew rather than 3 Zoltan crew for narrative purposes in a video series I'm working on this year, however every time I do the weapons are broken in the process.


As you can see, the missile weapon is floating off into the void and the beam weapon just flat out isn't there, or at least it's not showing up (even if powered). Does anyone have any idea what might be causing this?

Re: [TOOL]FTLEdit: FTL Ship editor [v0.91 18th Dec] Open sou

Posted: Tue Jan 08, 2013 10:41 am
by alextfish
Looks like all the mount points have been lost. I'd recommend you don't use FTLEdit for this: just create a very simple zip file containing nothing but a blueprints.xml.append file containing the <shipBlueprint> for the Zoltan cruiser, tweaked as you wish.

I see a lot of people on this thread who're wanting to use FTLEdit like MSWord or something: make a mod, find it's not quite right, load the mod back into FTLEdit to change it, save it again, discover another tweak you want to make, load it back into FTLEdit etc.

FTLEdit really isn't designed to work that way. FTLEdit is a design tool, for laying out the floor layout of the rooms/doors in a custom ship. It's intended to be used once, to create a floor layout; then you export the ship and make any remaining tweaks by hand. The Options dialog is a good way to specify most of the parameters for a newly created ship, but it's really not a sensible thing to use to just adjust a ship.

For this kind of edit where you're not changing the floor plan, I strongly recommend you create a simple mod outside of FTLEdit. Create a directory called data; within that directory create a text file called blueprints.xml.append; edit that file and paste into it the <shipBlueprint> defining the Zoltan cruiser, which you'll find in your resources/data.dat-unpacked/data directory, in the file called blueprints.xml, starting around line 3500. Zip up the data directory, rename the zip file to end .ftl, and bingo, you have your mod. It's really best done from outside FTLEdit.

Modding FTL is not going to be a drag-and-drop button-clicking task. You're going to have to edit some text files. That's just the simple fact of the available tools at the moment.

Darkfrost has built us a great hammer here, which is very useful for hammer-type things. But it's not a Swiss Army Knife.

(Now, as a potential future development direction should Darkfrost wish to do this, it would be seriously awesome if FTLEdit could load a .ftl file to get the blueprint, layout and images all from one place, and remember all the settings like room and shield and cloak images; and then write out the .ftl file to a target location in the filesystem. That would alleviate a lot of the pain felt by visitors to the forum who expect it to work that way. But that's not what FTLEdit does right now, and we really can't blame Darkfrost for not doing that because it would be a lot of work.)

Re: [TOOL]FTLEdit: FTL Ship editor [v0.91 18th Dec] Open sou

Posted: Tue Jan 08, 2013 2:17 pm
by Disc10
Ahhhh, fair enough! You see I also tried editing the blueprint file manually, however I didn't do it as an .append file, which may have been where I was going wrong. But yes, using wrong tool in the wrong way will not have helped. :P

However... I'm still running into issues, but that's not really on topic now so I shall decant to a new thread: viewtopic.php?f=12&t=10571

Thank you for the response. :D

FTLEdit: FTL Ship editor NEW: [v0.95 11th Jan]

Posted: Fri Jan 11, 2013 1:23 am
by Darkfrost
New version!

- Added a 'Save Paths' button in the options - If you were pasting the path into the textbox instead of using the browse button, they weren't saving!
- Added an 'export all' button
- Will now load in the Gibs / Weapon mounts from the xml file and save them back out after. There's no way of editing these yet, but now they wont all get load when you load and save a ship!
*It will however, assume your gibs are in order in the blueprint file, and ignore the actual <gibX> number, since the end tags on those are messed up and this kept breaking the importing.
- Added options to change the maxpower / health settings
- Imports shield size correctly now

Same url:

Re: [TOOL]FTLEdit: FTL Ship editor [v0.95 11th Jan] Open sou

Posted: Sat Jan 12, 2013 4:49 am
by Splitstack
Still have the problem where the ship background image and floor is shifted up and left. I don't encounter the problem if I make no changes to the rooms, i.e I can add doors and save it and be fine.

Also have this weird thing in the ship building part where the top left corner of the program is unresponsive/my mouse pointer is not aligned to where it really is. My mouse pointer is in one square and if I put down anything the room ends up 1 square down and 1 square to the right. If I shift the screen to the down and right with the arrow button then the mouse alignment issue occurs in more areas.

Re: [TOOL]FTLEdit: FTL Ship editor [v0.95 11th Jan] Open sou

Posted: Sat Jan 12, 2013 3:38 pm
by Darkfrost
Could you post a screenshot of that or something? Or directions to reproduce it?

Re: [TOOL]FTLEdit: FTL Ship editor [v0.95 11th Jan] Open sou

Posted: Sat Jan 12, 2013 6:47 pm
by Splitstack
So I'm using FTL from Steam.
Gognak's mod manager v1.5
Installed mods: Beginning Scrap advantage (came with the mod manager and needed to get the resource folders)
Modified save file to get access to all ships

Modifying the Shivan in the ship editor:
Cursor problem
Occurs when I load an existing ship from game folder but not when I create a ship from scratch. Is not unique to Shivan

Here it is normal: Black arrow shows where my cursor is on the screen


Here is where the my cursor no longer corresponds to where it is in the program. The red arrow is where my cursor is.


Now if I use the direction keys in the program and shift the entire thing down and to the right the mis match cursor area increases.The Red arrow is where my cursor is and the red square now corresponds to the entire area my cursor will be messed up in.


Now for the problem when adding the ship into the game

Changing the Shivan again.
-load existing ship from game
-delete all rooms
-make new layout superimposed on base (make sure it matches)
-options -> export ship
-export ftl package
-use mod manager to import ship so I can check in the hangar

Changing doors only:


Restoring backup

Changing rooms:



Re: [TOOL]FTLEdit: FTL Ship editor [v0.95 11th Jan] Open sou

Posted: Sat Jan 12, 2013 8:36 pm
by temotodochi
I'm here because of the trojanized ftldat.exe. I ran it through f-secure testing laboratory(*) and it was loaded with 2 trojans. In the screenshot you can see that it actually downloaded 2 unwanted executable files.

*): the way f-secure lab works is it runs automatically the program in actual working operating system and sees what it does, files it drops etc.


Re: [TOOL]FTLEdit: FTL Ship editor [v0.95 11th Jan] Open sou

Posted: Sat Jan 12, 2013 11:38 pm
by boa13
Since you posted this in two places, here's a copy of my reply:

boa13 wrote:Hey, please don't post your excessively big screenshot in several threads! :evil:

You totally misunderstood what was in the screenshot! There is no "two trojans". There is no trojan!

In your screenshot, there are two antivirus programs (Aquarius and Hydra OS X) that mistakenly think ftldat.exe is a trojan.

You will notice that Hydra PC is not fooled, along with eight other antivirus programs who are fine with ftldat.exe!

Re: [TOOL]FTLEdit: FTL Ship editor [v0.95 11th Jan] Open sou

Posted: Sun Jan 13, 2013 3:10 am
by Darkfrost
Thank you so much Splitstack!

I fixed the first bug, that'll be sorted in the next version

The second one seems harder to fix, after a bit of debugging, it seems like it happens when you move one of the rooms upwards (so the Y is at -1), causing the whole thing to get shifted down ingame (but not the background)