Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Discuss and distribute tools and methods for modding. Moderator - Grognak
Jaggedmallard
Posts: 18
Joined: Sat Apr 20, 2013 10:06 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby Jaggedmallard » Sun Apr 21, 2013 11:29 am

I see. I didn't realise I was supposed to open up the .FTL file as an example on how it works. Thanks.
Also running main.py worked great. I tried it earlier but nothing happened at first so I though it just didn't work. I feel really stupid but thanks for the help :D
lysgb
Posts: 2
Joined: Sun Apr 21, 2013 9:04 am

Error - ideas?

Postby lysgb » Mon Apr 22, 2013 6:18 pm

15:53:19 ERROR: Unexpected exception in LogicThread.
Traceback (most recent call last):
File "C:\Játékok\FTL\Grognaks Mod Manager v1.7 Win32\Grognaks Mod Manager v1.7 Win32\main.py", line 1130, in run
self._process_event_queue(0.5) # Includes some blocking.
File "C:\Játékok\FTL\Grognaks Mod Manager v1.7 Win32\Grognaks Mod Manager v1.7 Win32\main.py", line 1159, in _process_event_queue
self._process_event(action_name, arg_dict)
File "C:\Játékok\FTL\Grognaks Mod Manager v1.7 Win32\Grognaks Mod Manager v1.7 Win32\main.py", line 1167, in _process_event
self._config_loaded(arg_dict)
File "C:\Játékok\FTL\Grognaks Mod Manager v1.7 Win32\Grognaks Mod Manager v1.7 Win32\main.py", line 1242, in _config_loaded
arg_dict["config_parser"].write(cfg_file)
File "C:\Python27\lib\ConfigParser.py", line 412, in write
key = " = ".join((key, str(value).replace('\n', '\n\t')))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe1' in position 4: ordinal not in range(128)
n00bshotgunner
Posts: 2
Joined: Mon Apr 22, 2013 9:28 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby n00bshotgunner » Mon Apr 22, 2013 9:37 pm

When I run the modman.exe, it says:

Code: Select all

No supported version of Python found on this system. Download Python 2.7.3 at: www.python.org/getit. Press Enter to continue...
What do I do? I have Python 2.7.4 downloaded, is that the problem?
User avatar
kartoFlane
Posts: 1479
Joined: Mon Jan 14, 2013 10:20 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby kartoFlane » Mon Apr 22, 2013 10:20 pm

@n00bshotgunner
Double-click main.py instead of modman.exe
Superluminal2 - a ship editor for FTL
n00bshotgunner
Posts: 2
Joined: Mon Apr 22, 2013 9:28 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby n00bshotgunner » Tue Apr 23, 2013 12:03 am

kartoFlane wrote:@n00bshotgunner
Double-click main.py instead of modman.exe

Thanks!
Loki
Posts: 1
Joined: Mon Apr 22, 2013 11:59 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby Loki » Tue Apr 23, 2013 12:04 am

When I try running via modman.exe I receive this error:

Code: Select all

No supported version of Python found on this system. Download Python 2.7.3 at: www.python.org/getit. Press Enter to continue...

I have Python 2.7.4 installed. I've tried both 64 and 32 bit distributions of Python to no avail.

kartoFlane wrote:@n00bshotgunner
Double-click main.py instead of modman.exe

I tried that, but I get an error logged:

Code: Select all

2013-04-22 18:58:14 ERROR: DLL load failed: %1 is not a valid Win32 application.
Traceback (most recent call last):
  File "C:\Users\Franco\Desktop\gmm\main.py", line 72, in <module>
    globals()[new_name] = __import__(old_name, globals(), locals(), [])
  File "C:\Python27\lib\lib-tk\Tkinter.py", line 38, in <module>
    import FixTk
  File "C:\Python27\lib\lib-tk\FixTk.py", line 65, in <module>
    import _tkinter
ImportError: DLL load failed: %1 is not a valid Win32 application.


:\ I have no idea what to do.

edit: I got GMM running :) I had to completely remove Python and GMM from my computer and reinstall Python 32-bit. After that, I had to change permissions for main.py file. Finally,I had to open with main.py instead of modman.exe as mentioned by someone earlier.
Last edited by Loki on Tue Apr 23, 2013 12:12 am, edited 1 time in total.
User avatar
kartoFlane
Posts: 1479
Joined: Mon Jan 14, 2013 10:20 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby kartoFlane » Tue Apr 23, 2013 12:12 am

*shrug* Guess you'll have to wait for Vhati or Grognak to show up in order to help out with this one.
Though if I were to guess, I'd say that when you were trying out different distributions of python, you've installed 64-bit later. So now your OS is trying to run a 64-bit python on 32-bit architecture.
Try to uninstall python completely and then install the 32-bit version again (if your system is 32-bit, 64 otherwise)

edit
@up
Oh. Well, looks like I guessed right :E
Superluminal2 - a ship editor for FTL
kf177045
Posts: 6
Joined: Tue Apr 23, 2013 6:54 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby kf177045 » Tue Apr 23, 2013 7:22 pm

Here is how to fix "No supported version of Python found on this system" the proper way:
1. Click Start, right-click "Computer" ("My Computer" on Windows XP) then click "Properties":
modman1.jpg

2. On Windows 7, click "Advanced system settings". Click "Yes" at UAC prompt:
modman2.jpg

3. Click "Advanced" tab if not already selected, then click "Environment Variables...":
modman3.jpg

(continued in the next post)
kf177045
Posts: 6
Joined: Tue Apr 23, 2013 6:54 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby kf177045 » Tue Apr 23, 2013 7:40 pm

How to fix "No supported version of Python found on this system" part 2:
4. Under "System variables" locate and highlight "Path" variable then click "Edit...":
modman4.jpg

5. Press Home key then type "C:\Python27;" including the semicolon but without quotes. (If you have Python 2.6.x type "C:\Python26;" instead and if you have installed Python in different location then change the path accordingly):
modman5.jpg

7. Click "OK" thee times to close all dialog boxes.
8. Restart your system.
daveking
Posts: 8
Joined: Wed Apr 24, 2013 8:54 am

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby daveking » Wed Apr 24, 2013 9:10 am

[b]Problem!!

I'm on windows 7, which is a 64-bit OS, I've installed Python 2.7.3 and changed the Path in the Environment variables to the Python's home folder in C:

I've got the mod manager open and ready to accept commands.

I'm using Superluminal FTL editor and I've made alterations to a ship with it, I've then exported the edited ship as a .ftl file to the mods folder in GMM.

Inside the GMM screen, it sees the mod and identifies it as "stealth ship" which I assume is the ship I've created. However, when I press "patch" it gives me an error message saying, "patch failed. See log for details"

So I need to....

1. Know where the log is, I can't find it, so I can copy it here to show you.

2. have someone tell me if it's because the ship I edited is faulty in some way? for ex, I put the system power setting at 70 when the maximum is 25, could things like that stop my ship patch working?

Who is online

Users browsing this forum: No registered users and 12 guests