Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Discuss and distribute tools and methods for modding. Moderator - Grognak
NineZeroZeroOne
Posts: 3
Joined: Thu Aug 08, 2013 5:37 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby NineZeroZeroOne » Thu Aug 08, 2013 5:57 pm

Absolutely superb mod. Thank you, good sir!
ultramario1998
Posts: 1
Joined: Fri Aug 09, 2013 2:24 am

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby ultramario1998 » Fri Aug 09, 2013 2:30 am

Hey,
I need help with using the tool on OSX. Whenever I attempt to patch the game (Steam copy) I get the following error in the terminal window:

Code: Select all

ERROR: Unexpected exception in LogicThread.
Traceback (most recent call last):
  File "main.py", line 1130, in run
    self._process_event_queue(0.5)  # Includes some blocking.
  File "main.py", line 1159, in _process_event_queue
    self._process_event(action_name, arg_dict)
  File "main.py", line 1173, in _process_event
    self._patching_finished(arg_dict)
  File "main.py", line 1336, in _patching_finished
    ftl_exe_path = find_ftl_exe()
  File "main.py", line 894, in find_ftl_exe
    if (os.path.isfile(os.join(app_path, "Contents", "Info.plist"))):
AttributeError: 'module' object has no attribute 'join'

If anyone has advice on how to solve this problem, I'd be very grateful. :)
User avatar
kartoFlane
Posts: 1480
Joined: Mon Jan 14, 2013 10:20 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby kartoFlane » Fri Aug 09, 2013 12:03 pm

@ultramario
Try this
Superluminal2 - a ship editor for FTL
daj327
Posts: 4
Joined: Fri Sep 28, 2012 10:17 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby daj327 » Sat Aug 10, 2013 8:54 pm

So, I'm having some trouble. I got this error.

[Errno 13] Permission denied: u'C:/Program Files (x86)/FTL/resources\\data.dat'
Traceback (most recent call last):
File "C:\Users\Devan\Desktop\Grognaks Mod Manager v1.7 Win32\lib\killable_threading.py", line 99, in run
result = self._payload(*self._payload_args, **self._payload_kwargs)
File "C:\Users\Devan\Desktop\Grognaks Mod Manager v1.7 Win32\main.py", line 782, in patch_dats
sh.copy2(bak_path, dat_path)
File "C:\Python27\lib\shutil.py", line 128, in copy2
copyfile(src, dst)
File "C:\Python27\lib\shutil.py", line 83, in copyfile
with open(dst, 'wb') as fdst:
IOError: [Errno 13] Permission denied: u'C:/Program Files (x86)/FTL/resources\\data.dat

I followed all the troubleshooting, ran as admin, all that. Still didn't work.
User avatar
kartoFlane
Posts: 1480
Joined: Mon Jan 14, 2013 10:20 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby kartoFlane » Sat Aug 10, 2013 10:52 pm

It's still saying that the manager was denied permission.
Get the fixed exe, place it in GMM's location (replace the old one), right click it and run it as admin.
If it's still saying that permission's denied, make sure that your account actually has admin rights, and that no other program is accessing these files while the manager is running.

Failing that, you can try working around the problem - since Windows Vista/7/8 locks access to Program Files for unauthorized apps, you can try changing the path to FTL in GMM's config file to some arbitrary location - for example, C:\\FTL_archives. Then run the manager and patch the files, and copy them over to FTL's real installation manually -- I've never actually tried that though, so it may not work.
Superluminal2 - a ship editor for FTL
SaniK
Posts: 3
Joined: Mon Aug 12, 2013 5:41 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby SaniK » Mon Aug 12, 2013 6:47 pm

this mod says I need Python 2.7.3

1. That is bull shit why do I need another software (python 2.7.3) to run your software? :cry:

2. why dont you have this software dl link in your thread or any explanation about it?
User avatar
kartoFlane
Posts: 1480
Joined: Mon Jan 14, 2013 10:20 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby kartoFlane » Mon Aug 12, 2013 8:39 pm

Python is a programming language in which GMM written. Since the language is interpreted (ie, not compiled to machine code), your PC has to have an interpreter installed. Some systems have it by default.
*shrug* I guess Grognak didn't consider it to be significant, or assumed that Python is commonly recognized.
Superluminal2 - a ship editor for FTL
UltraMantis
Posts: 2141
Joined: Thu Sep 20, 2012 3:17 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby UltraMantis » Mon Aug 12, 2013 10:52 pm

It's not uncommon to have a program depend on another in order to run. Almost all games require DirectX, Youtube videos dont play without Adobe Flash, a whole bunch of apps require Java. Maybe Python is less recognised, but it's still the same thing. It's not a big deal unless you have to pay for a dependancy which is usually never the case.

GMM has evolved a lot since it's inception, and has allways been an invaluable tool. It's not perfect, but the fact it requires Python is hardly a problem. Google the latest version for your OS and install it. It's not a toolbar or some malware crap, it's like kartoFlane said an interpreter that runs apps programmed for it. One of the reasons this is actually usefull is that it doesn't matter what OS or computer you have, it will run on Windows, OSX or various Linux distros.
Report spam using the handy Report Button Mod.
SaniK
Posts: 3
Joined: Mon Aug 12, 2013 5:41 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby SaniK » Thu Aug 15, 2013 5:49 pm

kartoFlane wrote:Python is a programming language in which GMM written. Since the language is interpreted (ie, not compiled to machine code), your PC has to have an interpreter installed. Some systems have it by default.
*shrug* I guess Grognak didn't consider it to be significant, or assumed that Python is commonly recognized.


Sorry, Ive never heard of it. I run Windows 7 64bit, could you please help me step by step on what I need to get the mod manager working on my machine?

Do I DL the latest version of python or that specific one his mod asks me for?
User avatar
kartoFlane
Posts: 1480
Joined: Mon Jan 14, 2013 10:20 pm

Re: Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Postby kartoFlane » Thu Aug 15, 2013 6:27 pm

Download and install Python 2.7.5 (or newer) from here - be sure to get the correct distribution for your system (32-/64-bit).
The 3.x.x version is fine too, I guess, but IIRC the 2.x.x is better supported, so just stick with it for now.

Then download GMM. You may also want to get the fixed exe for GMM (since the stock one is broken and never detects Python correctly - you'd have to double-click main.py in order to run the program).

Aaand that's about it. Happy modding.
Superluminal2 - a ship editor for FTL

Who is online

Users browsing this forum: No registered users and 28 guests