Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Discuss and distribute tools and methods for modding. Moderator - Grognak
Grognak
Posts: 172
Joined: Tue Sep 18, 2012 9:42 pm

Re: Grognak's Mod Manager v1.5 (Updated Dec 19 2012!)

Postby Grognak » Mon Dec 24, 2012 2:16 am

Sorry for all those having problems with the Mac version. I'll try to see about releasing a new version after the holidays.

@X: Go ahead and PM me if you can't post the issue on the thread. (I can't imagine what would be "awkward" enough to not be able to post :lol: )
UltraMantis
Posts: 2141
Joined: Thu Sep 20, 2012 3:17 pm

Re: Grognak's Mod Manager v1.5 (Updated Dec 19 2012!)

Postby UltraMantis » Mon Dec 24, 2012 6:11 am

Anyone experiencing problems with various mods after updating to latest version of FTL (1.03.1), take a look at this post:
viewtopic.php?f=11&t=3107&start=60#p32214
Report spam using the handy Report Button Mod.
Xartyr
Posts: 1
Joined: Mon Dec 24, 2012 6:14 am

Re: Grognak's Mod Manager v1.5 (Updated Dec 19 2012!)

Postby Xartyr » Mon Dec 24, 2012 6:22 am

I run FTL on a mac, and I've scoured this whole topic (and the whole internet) to figure out how to install the mod manager.

I run FTL from Applications, and all the game data (just profile.sav and setting.ini - that's all there is) is in
Library/Application Support/FasterThanLight
Which was created automatically by the game.

I've tried running the mod manager according to the readme, and I put all the files in the FasterThanLight folder and ran it from there when all else failed. It just gives me errors and instructions to put things in the same folder as 'x' file: all the files ever named, I don't have. It's really frustrating because I don't know why I don't have a whole heap of these files that the mod manager need to be put with.

Sorry to bother you, but I would be really grateful if someone could explain to me why the way my mac runs appears to be different to how the instructions expect it to.

Thanks very much.
itk
Posts: 1
Joined: Mon Dec 24, 2012 10:58 am

Re: Grognak's Mod Manager v1.5 (Updated Dec 19 2012!)

Postby itk » Mon Dec 24, 2012 11:03 am

Hi there,

Recently got this game and found out there was a modding scene. Running windows 7 and while I can get your mod manager to run and identity the mods I'd like to install, I come to this error after it attempts to backup the two .dat files.

Image

I've tried reordering the mods and am not really sure what the problem is. My steam installation and all of the associated games are on an external HD, which is J:, while C: is my primary and only internal drive. The D: drive is simply a partition with the usual HP backup/restore stuff, so I'm kind of confused by this error being spit out if it's attempting to look for files there for some reason.

Any help is appreciated!
Vincam195
Posts: 15
Joined: Mon Nov 26, 2012 10:01 pm

Re: Grognak's Mod Manager v1.5 (Updated Dec 19 2012!)

Postby Vincam195 » Mon Dec 24, 2012 5:31 pm

Xartyr wrote:I run FTL on a mac, and I've scoured this whole topic (and the whole internet) to figure out how to install the mod manager.

I run FTL from Applications, and all the game data (just profile.sav and setting.ini - that's all there is) is in
Library/Application Support/FasterThanLight
Which was created automatically by the game.

I've tried running the mod manager according to the readme, and I put all the files in the FasterThanLight folder and ran it from there when all else failed. It just gives me errors and instructions to put things in the same folder as 'x' file: all the files ever named, I don't have. It's really frustrating because I don't know why I don't have a whole heap of these files that the mod manager need to be put with.

Sorry to bother you, but I would be really grateful if someone could explain to me why the way my mac runs appears to be different to how the instructions expect it to.

Thanks very much.


If you run FTL through Steam then I'm not sure if this would work still, but you'll get better results if you put all the GMM files needed (_init_.py, ftldat.py, main.py, and modman.ini) into Library/Application Support/Steam/SteamApps/common/FTL Faster Than Light.
Macspt
Posts: 24
Joined: Wed Dec 12, 2012 8:13 pm

Re: Grognak's Mod Manager v1.5 (Updated Dec 19 2012!)

Postby Macspt » Tue Dec 25, 2012 3:34 pm

Hey Guys,
Sorry about the delay with the video's, Christmas and all! I will get them posted as soon as I can.

Thanks!
FrgrantSkunk
Posts: 4
Joined: Thu Dec 20, 2012 1:35 am

Re: Grognak's Mod Manager v1.5 (Updated Dec 19 2012!)

Postby FrgrantSkunk » Tue Dec 25, 2012 7:08 pm

Macspt wrote:Hey Guys,
Sorry about the delay with the video's, Christmas and all! I will get them posted as soon as I can.

Thanks!

Don't apologize! You're doing us all a great favour. It's very kind of you to make the video.
Macspt
Posts: 24
Joined: Wed Dec 12, 2012 8:13 pm

Re: Grognak's Mod Manager v1.5 (Updated Dec 19 2012!)

Postby Macspt » Wed Dec 26, 2012 4:19 am

Hey Guys,
I am recording the video at a higher quality. I will post it as soon as possible. Thanks! ;)
Last edited by Macspt on Wed Dec 26, 2012 10:39 pm, edited 1 time in total.
RealKleiner
Posts: 2
Joined: Wed Dec 26, 2012 8:20 pm

Re: Grognak's Mod Manager v1.5 (Updated Dec 19 2012!)

Postby RealKleiner » Wed Dec 26, 2012 9:01 pm

Hey Grognak. There is a issue with the mod manager and Python 3.3 on Linux. First off. all print functions are called incorrectly, easy to fix. Also they changed how you use the from/import functions, for example:

Code: Select all

from ConfigParser import SafeConfigParser
from Tkinter import *

should be:

Code: Select all

from configparser import SafeConfigParser
from tkinter import *


also, on line 10 in main.py, it should be:

Code: Select all

import tkinter as msgbox


Then there is alot of other stuff to fix/change, I tried and fix it, but my Python is a bit rusty.
boa13
Posts: 829
Joined: Mon Sep 17, 2012 11:42 pm
Location: Nantes, France

Re: Grognak's Mod Manager v1.5 (Updated Dec 19 2012!)

Postby boa13 » Wed Dec 26, 2012 9:25 pm

The Mod Manager is a Python 2 program; it does not work with Python 3.

So, install Python 2, and run the Mod Manager using Python 2. Typically, on most Linux distributions, Python 2 can be installed alongside Python 3, since both versions are currently actively maintained.
Forum janitor — If you spot spam, PM me the URL and/or the username of the spammer.
I have powers, moderator powers. I am not keen on using them, but will do so if needed.

Who is online

Users browsing this forum: No registered users and 29 guests