Grognak's Mod Manager v1.7 (Updated March 6, 2013!)

Discuss and distribute tools and methods for modding. Moderator - Grognak
jocelyn
Posts: 6
Joined: Mon Nov 12, 2012 5:57 pm

Re: Grognak's Mod Manager v1.4.1 (Updated Nov 9 2012!)

Postby jocelyn » Sat Dec 15, 2012 8:56 pm

Macspt wrote:9. In the terminal type the following:
chmod 777
10. Drag the Gmm.command file from your desktop into the Terminal window, and it should again auto populate the path to the file.
chmod 777 ~/desktop/GMM.command


Hi again,

Just an FYI, it's generally bad practice to set permissions to 777 unnecessarily, and it's somewhat (albeit minor) irresponsible to suggest/teach people that are new to the shell/terminal to use 777. For those that don't know, "777" means anyone that ever gains access to your system can read, write/modify, and execute the file in question.

This is why I originally suggested:

Code: Select all

chmod ug+x

since it only adds the execute permission for the current user, and their corresponding user group.

Alternatively you could use 770 (user and group can read/write/execute, everyone else cannot access) or 775 (user and group can read/write/execute, everyone else can only read/execute, cannot modify/write.)

Anyway, glad people are getting this working, cheers everyone :)
Macspt
Posts: 24
Joined: Wed Dec 12, 2012 8:13 pm

Re: Grognak's Mod Manager v1.4.1 (Updated Nov 9 2012!)

Postby Macspt » Sat Dec 15, 2012 10:16 pm

jocelyn wrote:
Macspt wrote:9. In the terminal type the following:
chmod 777
10. Drag the Gmm.command file from your desktop into the Terminal window, and it should again auto populate the path to the file.
chmod 777 ~/desktop/GMM.command


Hi again,

Just an FYI, it's generally bad practice to set permissions to 777 unnecessarily, and it's somewhat (albeit minor) irresponsible to suggest/teach people that are new to the shell/terminal to use 777. For those that don't know, "777" means anyone that ever gains access to your system can read, write/modify, and execute the file in question.

This is why I originally suggested:

Code: Select all

chmod ug+x

since it only adds the execute permission for the current user, and their corresponding user group.

Alternatively you could use 770 (user and group can read/write/execute, everyone else cannot access) or 775 (user and group can read/write/execute, everyone else can only read/execute, cannot modify/write.)

Anyway, glad people are getting this working, cheers everyone :)


1. I have updated the instructions and changed it to 700. :oops:
Thanks Jocelyn!
MrHoody
Posts: 23
Joined: Sat Dec 15, 2012 12:33 pm

Re: Grognak's Mod Manager v1.4.1 (Updated Nov 9 2012!)

Postby MrHoody » Sun Dec 16, 2012 2:43 am

Hello again everyone! When I double-click the GMM.command file, it still says I don't have appropriate access privileges :?:

Side note: I am an admin of the computer and have changed the settings to read & write for the file. (Just in case that info is important or something)
Macspt
Posts: 24
Joined: Wed Dec 12, 2012 8:13 pm

Re: Grognak's Mod Manager v1.4.1 (Updated Nov 9 2012!)

Postby Macspt » Sun Dec 16, 2012 3:02 am

MrHoody wrote:Hello again everyone! When I double-click the GMM.command file, it still says I don't have appropriate access privileges :?:

Side note: I am an admin of the computer and have changed the settings to read & write for the file. (Just in case that info is important or something)


What chmod permissions did you use? ug+x or 777 or 700? If you use 777 there is absolutely no reason it should not work. Try ug+x first to make Jocelyn happy. ;)
MrHoody
Posts: 23
Joined: Sat Dec 15, 2012 12:33 pm

Re: Grognak's Mod Manager v1.4.1 (Updated Nov 9 2012!)

Postby MrHoody » Sun Dec 16, 2012 4:14 am

Macspt wrote:
MrHoody wrote:Hello again everyone! When I double-click the GMM.command file, it still says I don't have appropriate access privileges :?:

Side note: I am an admin of the computer and have changed the settings to read & write for the file. (Just in case that info is important or something)


What chmod permissions did you use? ug+x or 777 or 700? If you use 777 there is absolutely no reason it should not work. Try ug+x first to make Jocelyn happy. ;)


Maybe if I post a screenshot it'll be easier for you to find out what's wrong. Really sorry if I'm being a nuisance with my lack of computer knowledge and stuff :oops: :oops: :oops:
Acid Ant
Posts: 1
Joined: Sun Dec 16, 2012 1:33 pm

Re: Grognak's Mod Manager v1.4.1 (Updated Nov 9 2012!)

Postby Acid Ant » Sun Dec 16, 2012 1:37 pm

I am having a problem where none of the .ftl files are registering. help would be appreciated
Macspt
Posts: 24
Joined: Wed Dec 12, 2012 8:13 pm

Re: Grognak's Mod Manager v1.4.1 (Updated Nov 9 2012!)

Postby Macspt » Sun Dec 16, 2012 5:48 pm

MrHoody wrote:
Macspt wrote:
MrHoody wrote:Hello again everyone! When I double-click the GMM.command file, it still says I don't have appropriate access privileges :?:
Maybe if I post a screenshot it'll be easier for you to find out what's wrong. Really sorry if I'm being a nuisance with my lack of computer knowledge and stuff :oops: :oops: :oops:


Hey Bud, screenshots are always a big help! I would delete your current GMM.command and create a new one. Looks like you are missing some spaces between some of the command parts.

1. When creating the GMM.command file, your command line should look like this:
herman-cher-mains-macbook:~ Huds$ echo "python /Applications/FTL.app/Contents/main.py" > ~/desktop/GMM.command

2. When changing the permissions for the GMM.command file, your command line should look like this:
herman-cher-mains-macbook:~ chmod ug+x ~/Desktop/GMM.command
-or-
herman-cher-mains-macbook:~ chmod ug+x /Users/Hud/Desktop/GMM.command

Hope this helps! :)
Macspt
Posts: 24
Joined: Wed Dec 12, 2012 8:13 pm

Re: Grognak's Mod Manager v1.4.1 (Updated Nov 9 2012!)

Postby Macspt » Sun Dec 16, 2012 5:53 pm

Acid Ant wrote:I am having a problem where none of the .ftl files are registering. help would be appreciated


Hey Acid,
Where are you placing the files?

If you are placing them in /Applications/FTL.app/Contents/Mods, and they are not working, you need to instead place them in /Users/YourUSERname/Documents/FTL Mods.


The "modman.ini" file is set to create a "FTL mods" folder in your documents folder.
--------------------------------------------------------
# Sets the directory for mods (Mac OS X only)
macmodsdir = ~/Documents/FTL mods
--------------------------------------------------------
So simply place your mods file in the "FTL Mods" folder inside your "Documents" folder and they should work fine.
For example, I would place my mods in: /Users/ghost/documents/FTL mods

You can change your "modman.ini" if you want to make it something else.
1. Go to the "Contents" folder of the game.
2. Right click on "modman.ini" and click Open With -> Textedit.
3. Replace "~/Documents/FTL mods" with the path you wish to use.
I used the "mods" folder inside the "Contents" folder since that is what the documentation said to do.
Example: macmodsdir = /Users/ghost/Desktop/FTL.app/Contents/mods
4. Save out the file and relaunch GMM.
5. Also note that the "Modorder.txt" file specifies in which order your mods will be loaded. If there is a mod which is not loading properly, try moving it to the top of the "modorder.txt" file. You may need to copy this file from your "~/Documents/FTL\ Mods" folder to the "/Contents/Mods" folder if you wish to use that one.
6.I noticed that when I load the mods, the first "Tk" box that appears hangs the process. If you close this box the process will continue normally. If you have your "Terminal" window open when running GMM, you can notice what I am talking about.
Grognak
Posts: 172
Joined: Tue Sep 18, 2012 9:42 pm

Re: Grognak's Mod Manager v1.4.1 (Updated Nov 9 2012!)

Postby Grognak » Mon Dec 17, 2012 12:30 am

I'm going to ship 1.5 soon (after I figure out why pyinstaller is now nonfunctional...)

Does this changelog look right? If there's any quick fixes that'll help mac users, let me know.
1.5:
- Add option to select all mods automatically (on by default, changeable in .ini)
- .ini finding improvement (by Jocelyn)
Macspt
Posts: 24
Joined: Wed Dec 12, 2012 8:13 pm

Re: Grognak's Mod Manager v1.4.1 (Updated Nov 9 2012!)

Postby Macspt » Mon Dec 17, 2012 2:19 am

Grognak wrote:I'm going to ship 1.5 soon (after I figure out why pyinstaller is now nonfunctional...)

Does this changelog look right? If there's any quick fixes that'll help mac users, let me know.
1.5:
- Add option to select all mods automatically (on by default, changeable in .ini)
- .ini finding improvement (by Jocelyn)


Question?
Are you going to change the instructions to reflect that Mac users should put their *.ftl files in ~/Documents/FTL Mods?
-or-
Are you going to change the modmain.ini to look for *.ftl files in /Applications/FTL.app/Contenst/Mods folder?

Also, what is the first small "tk" box that appears? It hangs the process on the Mac side unless you close it.

Thanks! :mrgreen:

Who is online

Users browsing this forum: No registered users and 28 guests