Slipstream Mod Manager v1.9.1 (2018-01-07)

Discuss and distribute tools and methods for modding. Moderator - Grognak
KarlssoNN
Posts: 8
Joined: Wed Dec 13, 2017 6:28 am

Re: Slipstream Mod Manager v1.9 (2017-12-12)

Postby KarlssoNN » Wed Dec 13, 2017 7:09 am

Hi, Perhaps it's just me but "Extended Pursuit Indicator x24 with numbers" is not working for me since upgrading to 1.7/1.8/1.9. Unfortunately I had the disappearing cursor bug and have been using the latest beta game version 1.6.2. Mentioned mod was working with older Slipstream version 1.6.

Mod list:
Better Planets and Backgrounds
CE Resource Pack
FTL Captain's Edition
CE BPaB Compatibility Patch
CE Additional Music Addon
EL Texture Pack
CE Endless Loot Addon standard CE
CE Non-EL Enemy Loadouts Addon
Extended Pursuit Indicator x24 with numbers
Random Flagship
Rand-[trel/orus/asio/wark/a Monster/prey]
Expanded Enemy Window 1.2

Thanks for your fine service!!! Havin't tried vanilla but this game modded is a blast!!!
Vhati
Posts: 792
Joined: Thu Oct 25, 2012 12:01 pm

Re: Slipstream Mod Manager v1.9 (2017-12-12)

Postby Vhati » Wed Dec 13, 2017 8:03 am

KarlssoNN wrote:"Extended Pursuit Indicator x24 with numbers" is not working for me [...] been using the latest beta game version 1.6.2. Mentioned mod was working with older Slipstream version 1.6.
It sounds like you're saying a mod that had been made for FTL 1.5.13... isn't working on FTL 1.6.2?

*clickety-click*

Confirmed. That is the case.
SMM 1.9 can still successfully apply that mod to FTL 1.5.13.
SMM 1.9 w/ FTL 1.6.2 shows no visible changes.

That mod only contains one file ("img/ipad/map/map_warningcircle_point.png"). Vanilla FTL 1.6.2 no longer has such a file, so the result is you're modding something the game isn't paying attention to - hence no effect.

Not my fault. :D You should reply to the author's thread about releasing a variant specifically for FTL 1.6.2.

KarlssoNN wrote:Thanks for your fine service!!! Havin't tried vanilla but this game modded is a blast!!!
*Takes a bow*
KarlssoNN
Posts: 8
Joined: Wed Dec 13, 2017 6:28 am

Re: Slipstream Mod Manager v1.9 (2017-12-12)

Postby KarlssoNN » Wed Dec 13, 2017 11:14 am

Figured that was a possibility, should have done some testing, Thanks for your time!
User avatar
7636kei
Posts: 1
Joined: Fri Dec 15, 2017 12:14 pm

Re: Slipstream Mod Manager v1.9 (2017-12-12)

Postby 7636kei » Sun Dec 17, 2017 5:18 am

slowriderxcorps wrote:... because we're kind of running out of version numbers to go up to!


... not quite. Versioning that go 1.10 from 1.9 isn't quite unheard of. And that might be the next version they're going to, depending on how they number their version :P
Gearbull42
Posts: 1
Joined: Sun Dec 17, 2017 3:36 pm

Re: Slipstream Mod Manager v1.9 (2017-12-12)

Postby Gearbull42 » Sun Dec 17, 2017 3:39 pm

My slipstream mod manager isnt working properly and keeps asking me to find this file:
(FTL dir)/reasources/data.dat
What does this mean can someone help me
Vhati
Posts: 792
Joined: Thu Oct 25, 2012 12:01 pm

Re: Slipstream Mod Manager v1.9 (2017-12-12)

Postby Vhati » Sun Dec 17, 2017 6:18 pm

Gearbull42 wrote:My slipstream mod manager isnt working properly and keeps asking me to find this file:
(FTL dir)/reasources/data.dat
What does this mean can someone help me

The Mod Manager is up to 1.9 now, which asks a slightly different question.
It supports FTL 1.6.1+ but still works with FTL 1.01-1.5.13.

My previous stable release, SMM 1.6, only supported FTL 1.01-1.5.13.

As for the meaning... The mod manager splices in new images & text into the game. FTL keeps that stuff in the directory where you (or Steam) installed it. Older editions of FTL had a file named "data.dat". The new FTL 1.6.1+ has a file named "ftl.dat" that had a different file format than before - hence the need for a newer mod manager to recognize it.

Once it knows where to find the game's resources, Slipstream can start patching in mods.
Vhati
Posts: 792
Joined: Thu Oct 25, 2012 12:01 pm

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Postby Vhati » Sun Jan 07, 2018 9:27 pm

.
.
v1.9.1 has been released:
  • Edited a comment in boilerplate mod metadata to include AE ships.
  • Made the comments in boilerplace mod metadata optional.
  • Fixed omitted Validate warnings for PNG files.
  • Disabled XML escaping when reencoding to ensure invalid chars cause an error.
  • Added Validate warnings about FTL 1.6.1+ for TTF, MP3, and PNG files.
  • Added a Validate warning about FTL 1.5.13 for chars outside windows-1252.
  • Changed logging framework to SLF4J/Logback.
  • Changed command line parser to picocli.
  • Migrated to the Apache HttpComponents library.
  • Made launcher scripts on OSX find java the recommended way.

This update is primarily for mod developers.

The Validate button will generate migration-related warnings for FTL 1.6.1+ and backward compatibility warnings for FTL 1.5.13.
.
.
.
.
User avatar
bamalf
Posts: 160
Joined: Wed Dec 17, 2014 12:57 pm
Location: Russian

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Postby bamalf » Sun Jan 07, 2018 10:30 pm

Very useful, thank you! :)
Image Image Image
Lebebzio
Posts: 3
Joined: Fri Jan 12, 2018 4:29 pm

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Postby Lebebzio » Fri Jan 12, 2018 4:35 pm

I've also been having issues using the Extended Pursuit Indicator indicator mod with the Slipstream mod manager. I have only recently started playing again and decided to download this mod. I followed the instructions on the Subset games Mods page but I recieve an error whenever I try to validate the mod:
@ Extended Pursuit Indicater x24 with numbers v.1.2.ftl:
------------------------------------------------------

~ This mod doesn't append. It clobbers.


FTL itself can tolerate lots of XML typos and still run. But malformed XML may break tools that do proper parsing, and it hinders the development of new tools.

Since v1.2, Slipstream will try to parse XML while patching: first strictly, then failing over to a sloppy parser. The sloppy parser will tolerate similar errors, at the risk of unforseen behavior, so satisfying the strict parser is advised.


Does anyone know a fix?
Vhati
Posts: 792
Joined: Thu Oct 25, 2012 12:01 pm

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Postby Vhati » Fri Jan 12, 2018 6:23 pm

@Lebebzio: I posted a response in that thread.

Who is online

Users browsing this forum: No registered users and 9 guests