ship editor problems

Discuss and distribute tools and methods for modding. Moderator - Grognak
Rworqx
Posts: 39
Joined: Sun Jul 28, 2013 2:55 pm

ship editor problems

Postby Rworqx » Sun Jul 28, 2013 6:05 pm

ive got some problems with superluminal editor it wont launch. can someone help me please?

if you can make an video install tutorial for dummies it should be great and appreciated. (for me at least) :)
Last edited by Rworqx on Mon Jul 29, 2013 9:24 am, edited 2 times in total.
User avatar
kartoFlane
Posts: 1482
Joined: Mon Jan 14, 2013 10:20 pm

Re: ship editor problems

Postby kartoFlane » Sun Jul 28, 2013 6:39 pm

Make sure that you've downloaded the correct version for your OS (Windows/Mac/Linux) and distribution (32/64 bit), which refers to the version of Java you have installed (for example, Win 64 with 32-bit Java > download win_x32).
Make sure that your Java installation is up to date - the editor needs at least Java 1.7.

If you've made sure that all of the above are correct and the editor still doesn't launch, look for a debug.log or crash.log in the editor's directory. If there is, and has some text in it, paste it here.

If no log file is created, try running the superluminal.jar via command line (cd to superluminal's dir, then run
javaw -jar superluminal_(os-name)(version).jar -debug -IOdebug), it should spew some helpful info.
Superluminal2 - a ship editor for FTL
Rworqx
Posts: 39
Joined: Sun Jul 28, 2013 2:55 pm

Re: ship editor problems

Postby Rworqx » Sun Jul 28, 2013 8:31 pm

thanks but how you see wich java version youre running?
i did download 1.7
and the windows version 32 bit
Rworqx
Posts: 39
Joined: Sun Jul 28, 2013 2:55 pm

Re: ship editor problems

Postby Rworqx » Sun Jul 28, 2013 8:36 pm

someone needs to post how to install superlunimal for dummies
UltraMantis
Posts: 2141
Joined: Thu Sep 20, 2012 3:17 pm

Re: ship editor problems

Postby UltraMantis » Sun Jul 28, 2013 8:40 pm

If you click on Start Menu and then go to the Control Panel, you will find a shortcut to a Java control panel where you can check version, update and all that.
Report spam using the handy Report Button Mod.
Rworqx
Posts: 39
Joined: Sun Jul 28, 2013 2:55 pm

Re: ship editor problems

Postby Rworqx » Sun Jul 28, 2013 8:42 pm

ive got a windows 8 recently and thats kinda a problem i dont know where everything is located thanks for the fast reply tough
Rworqx
Posts: 39
Joined: Sun Jul 28, 2013 2:55 pm

Re: ship editor problems

Postby Rworqx » Sun Jul 28, 2013 8:47 pm

great i found it but it shut itself down
or do i need the latest gmm version? (i dont know how its exactly called)
User avatar
kartoFlane
Posts: 1482
Joined: Mon Jan 14, 2013 10:20 pm

Re: ship editor problems

Postby kartoFlane » Sun Jul 28, 2013 9:04 pm

Hm. Are there any log files?

To check java version, you can open the command prompt (no idea how it works on Win8, but should be the same -- click on Start, and in the search field type "cmd" and press enter), type java -version and press enter - it should print out the version number, along some other info.

Try launching the editor using the .bat file, see if anything new happens (log files, mostly)
If log files don't appear, open the .bat file with any text editor, and change the javaw to java, save, and try running it again. Hopefully there'll be something of use in the console.

And no, superluminal doesn't need GMM to run - you still need the manager to patch mods into the game, though.
Superluminal2 - a ship editor for FTL
Rworqx
Posts: 39
Joined: Sun Jul 28, 2013 2:55 pm

Re: ship editor problems

Postby Rworqx » Sun Jul 28, 2013 9:35 pm

thanks i try it

this what i get is this right?
java version "1.7.0_21"
Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)

Good thing i have command prompt in my toolbar:)
User avatar
kartoFlane
Posts: 1482
Joined: Mon Jan 14, 2013 10:20 pm

Re: ship editor problems

Postby kartoFlane » Sun Jul 28, 2013 10:03 pm

Rworqx wrote:Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)

This means that you've got Java 64-bit. So, download superluminal_win_x64 and all will be well.
Superluminal2 - a ship editor for FTL

Who is online

Users browsing this forum: No registered users and 42 guests