[Tool] FTL Ship Editor: Superluminal [NOT UPDATED TO AE]

Discuss and distribute tools and methods for modding. Moderator - Grognak
FTLChangeMahLife
Posts: 12
Joined: Sat Sep 21, 2013 11:44 pm
Location: SSV SR3 Normandy

Re: [Tool] FTL Ship Editor: Superluminal - version 13-11-12

Postby FTLChangeMahLife » Sun Dec 08, 2013 3:51 am

Hey, I've been using the Balanced Arsenal Mod and I've been wondering if there's any way to make a ship that starts with weapons from mods in Superliminal?
richeygator
Posts: 39
Joined: Fri Nov 01, 2013 10:59 pm
Location: south bend,indiana

Re: [Tool] FTL Ship Editor: Superluminal - version 13-11-12

Postby richeygator » Sun Dec 08, 2013 4:17 am

FTLChangeMahLife wrote:Hey, I've been using the Balanced Arsenal Mod and I've been wondering if there's any way to make a ship that starts with weapons from mods in Superliminal?

yes you have to go to file and find include mod then click that and lead it to the .ftl
I dont have a god complex,you have a mortal complex
Silver Of Infinity
Posts: 2
Joined: Sun Dec 22, 2013 6:34 am
Location: Australia
Contact:

Re: [Tool] FTL Ship Editor: Superluminal - version 13-11-12

Postby Silver Of Infinity » Sun Dec 22, 2013 7:18 am

I don't mean to trouble you, but I am on a mac and have made sure I have the latest version of java running. Yet the superluminal application refuses to open.

Exception in thread "Thread-1" java.lang.UnsupportedClassVersionError: com/kartoflane/superluminal/core/Main : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
logout

[Process completed]
Image
Lasers, Aliens and Starships.
User avatar
kartoFlane
Posts: 1480
Joined: Mon Jan 14, 2013 10:20 pm

Re: [Tool] FTL Ship Editor: Superluminal - version 13-12-22

Postby kartoFlane » Sun Dec 22, 2013 7:19 pm

Silver Of Infinity wrote:I don't mean to trouble you, but I am on a mac and have made sure I have the latest version of java running. Yet the superluminal application refuses to open.

I think I've found the reason... I've had the editor's project use the JDK library instead of JRE (basically, the developer version of the regular Java platform) -- I think that might have caused it not to recognise your Java version correctly.

Try the newest version and see if it works.
Also, you might want to reduce your signature image a little... It's a tad bit excessive in size :S

Let's call this a new version for clarity's sake; 13-12-22 changelog:
  • Fixed:
    • Since artillery apparently always uses the fifth weapon mount, the editor's export logic has been changed accordingly.
      All weapon mounts are now exported indiscriminately. If the ship has artillery system assigned, a comment will be printed next to the artillery mount in the layout.xml file, indicating that it is the artillery mount. Should the ship have less than 5 weapon mounts, but artillery system assigned, the user will be notified about the error (although the export process will not fail)
    • Removed a bit of code that would prevent error messages from being displayed, should an error occur during exporting.
    • Fixed the editor using a wrong Java library, (supposedly?) causing it to fail to run even if the user had Java 7.

Dropbox Download Directory: Superluminal 13-12-22
Alternative Github Download: Superluminal 13-12-22
Last edited by kartoFlane on Fri Dec 27, 2013 6:09 pm, edited 1 time in total.
Superluminal2 - a ship editor for FTL
DaDog99
Posts: 1
Joined: Thu Dec 26, 2013 4:42 am

Re: [Tool] FTL Ship Editor: Superluminal - version 13-12-22

Postby DaDog99 » Thu Dec 26, 2013 4:48 am

How do I make a room availabe from the start of a new game. (For Example: Drone room.)(I wanted to make a drone boarding ship 8-) . )

Edit: Nevermind; I found out how.
User avatar
Knightmarez
Posts: 143
Joined: Fri Nov 08, 2013 3:30 am

Re: [Tool] FTL Ship Editor: Superluminal - version 13-12-22

Postby Knightmarez » Fri Dec 27, 2013 1:02 pm

So one can add 5 weapons to a ship without artillery? some sort of rapid-fire machine?
User avatar
kartoFlane
Posts: 1480
Joined: Mon Jan 14, 2013 10:20 pm

Re: [Tool] FTL Ship Editor: Superluminal - version 13-12-22

Postby kartoFlane » Fri Dec 27, 2013 1:57 pm

Yes, you can. You can add 5 weapon to a ship with artillery, too - as far as I tested, the 5th weapon will use the 6th weapon mount in this case.
Superluminal2 - a ship editor for FTL
Boomhappy
Posts: 1
Joined: Fri Dec 27, 2013 5:51 pm

Re: [Tool] FTL Ship Editor: Superluminal - version 13-12-22

Postby Boomhappy » Fri Dec 27, 2013 5:54 pm

kartoFlane wrote:
Silver Of Infinity wrote:I don't mean to trouble you, but I am on a mac and have made sure I have the latest version of java running. Yet the superluminal application refuses to open.

I think I've found the reason... I've had the editor's project use the JDK library instead of JRE (basically, the developer version of the regular Java platform) -- I think that might have caused it not to recognise your Java version correctly.

Try the newest version and see if it works.
Also, you might want to reduce your signature image a little... It's a tad bit excessive in size :S

Let's call this a new version for clarity's sake; 13-12-22 changelog:
  • Fixed:
    • Since artillery apparently always uses the fifth weapon mount, the editor's export logic has been changed accordingly.
      All weapon mounts are now exported indiscriminately. If the ship has artillery system assigned, a comment will be printed next to the artillery mount in the layout.xml file, indicating that it is the artillery mount. Should the ship have less than 5 weapon mounts, but artillery system assigned, the user will be notified about the error (although the export process will not fail)
    • Removed a bit of code that would prevent error messages from being displayed, should an error occur during exporting.
    • Fixed the editor using a wrong Java library, causing it to fail to run even if the user had Java 7.

Dropbox Download Directory: Superluminal 13-12-22
Alternative Github Download: Superluminal 13-12-22


I tried the latest version you suggested, running java 7 on my mac, but it still gives crashes, citing

Exception in thread "Thread-1" java.lang.UnsupportedClassVersionError: com/kartoflane/superluminal/core/Main : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
logout
User avatar
kartoFlane
Posts: 1480
Joined: Mon Jan 14, 2013 10:20 pm

Re: [Tool] FTL Ship Editor: Superluminal - version 13-12-22

Postby kartoFlane » Fri Dec 27, 2013 6:09 pm

Well, there seems to be no reason for this error other than you having an old Java version. So this has to be something on your end -- there's nothing else that could possibly be wrong with the editor itself in this regard.

To make sure that your system is actually using the correct version, uninstall all Java versions, and then reinstall version 7.
Superluminal2 - a ship editor for FTL
General Tully
Posts: 3
Joined: Tue Sep 03, 2013 6:39 am

Re: [Tool] FTL Ship Editor: Superluminal - version 13-12-22

Postby General Tully » Mon Dec 30, 2013 11:17 pm

Can you please add in the ability to rotate ships? I'm trying to make enemy ships player ships, but when you play the game the entire ship alignment's wrong... :(

Who is online

Users browsing this forum: No registered users and 29 guests