[TUTORIAL] Creating Player Ships with FTLEdit

Discuss and distribute tools and methods for modding. Moderator - Grognak
Deploid
Posts: 3
Joined: Sun Feb 03, 2013 3:16 pm

Re: [TUTORIAL] Creating Player Ships with FTLEdit

Postby Deploid » Sun Feb 03, 2013 3:25 pm

mainly i need to know how to move the base picture(not the bg in ftledit the actual image that you see when playing)
Last edited by Deploid on Sun Feb 03, 2013 6:26 pm, edited 3 times in total.
Deploid
Posts: 3
Joined: Sun Feb 03, 2013 3:16 pm

Re: [TUTORIAL] Creating Player Ships with FTLEdit

Postby Deploid » Sun Feb 03, 2013 6:24 pm

Hey GingerDrangon i've been using ftledit for a while and i've gotten the problems down to one using this forum and others. i cant find out why but whenever is use a ship that i made in ftledit the texture is off but like 100 pixels. i've realised that basacly the texture of the ship(the new_ship_base and new_ship_floor) both start at the room block at the top right.if you want i can email you the .ftl and a pic.
FTLmodder28
Posts: 12
Joined: Sat Feb 09, 2013 9:33 am

Re: [TUTORIAL] Creating Player Ships with FTLEdit

Postby FTLmodder28 » Wed Feb 13, 2013 9:50 am

my problem happens which I use Beta 0.2 of Ship Edit and the doors end to bug out my editor forcing me to have to reopen not a big problem but when in the actual game my pictures are not aligned correctly, like Ships and whatnot, even the actual ship has to be resized and moved manually ;( FTL takes too long to load. When is the 0.3 beta coming out? I really need it! :cry:
Spearka
Posts: 20
Joined: Sat Jan 05, 2013 5:11 pm

Re: [TUTORIAL] Creating Player Ships with FTLEdit

Postby Spearka » Fri Feb 15, 2013 6:35 pm

i have been trying to make a ship through a combination of ftledit and another ftl ship creator, despite this i just cannot get it to work since ftl just crashes every damn time i load the ship, i just shows the same damn error message
1 - 0x004d568b
2 - 0x004d6c40
3 - 0x004db118
4 - 0x00556f52
5 - 0x005585c2
6 - 0x00538488
7 - 0x00403ed0
8 - 0x0059b1af
9 - 0x00403f6a
10 - 0x00406a62
11 - 0x00407379
12 - 0x005d5ceb
13 - 0x005d5da8
14 - 0x005d5676
15 - 0x004010b6
16 - 0x00401128
someone please tell me what this means, i tried everything, rooms, cloaking image, the whole deal but it just won't work!
speedoflight
Posts: 660
Joined: Mon Feb 18, 2013 11:08 am

Re: [TUTORIAL] Creating Player Ships with FTLEdit

Postby speedoflight » Thu Jun 13, 2013 6:12 pm

I dont think nobody will know wat those text lines means. Not even the authors of the game emselves.

Those crashes will probably caused by a wrong character, or a missing one, a blueprint with wrong values, and a large etc. Unless u can put your code here to examine, we can't do anything much to help u.. i never used FTL edit for ships (never worked for me, and since not even the author could help me or even heard me i just start using superluminal and superluminal is far better editor than ftl edit and with really greater support from the author).
My currently mods / wips ->
ImageImage
IamtheMoon
Posts: 1
Joined: Fri Aug 02, 2013 9:41 pm

Re: [TUTORIAL] Creating Player Ships with FTLEdit

Postby IamtheMoon » Sat Aug 03, 2013 7:05 pm

I am currently unable to proceed past step 6. I try to get my ship to appear in the hangar on FTL, but nothing has changed when I look for it in the game after patching it in.

The ship I was trying to replace was STEALTH_A. STEALTH_A is still there and nothing has changed.
---------------------

Here's what I can tell you right now.


All I know is that I have a file named
The Double-Vision-2013-08-03_11-36-10.ftl

as well as a folder named

The Double-Vision-2013-08-03_11-36-10

inside the folder is a folder named
The Double-Vision-2013-08-03_11-36-10
inside that folder are the data and img folders and a zipped folder named
The Double-Vision-2013-08-03_11-36-10

the img folder has the base and floor PNGs of my new ship.


All of these files are in the following directory:
C:\Program Files (x86)\Steam\SteamApps\common\FTL Faster Than Light\Grognaks Mod Manager v1.7 Win32\Grognaks Mod Manager v1.7 Win32\mods
----------------------
To clarify, DoubleVision is the name of my new ship.

I would greatly appreciate any help that can be provided in fixing this problem.
UltraMantis
Posts: 2141
Joined: Thu Sep 20, 2012 3:17 pm

Re: [TUTORIAL] Creating Player Ships with FTLEdit

Postby UltraMantis » Sun Aug 04, 2013 5:36 am

I suggest you examine an existing ship mod to see how various changes to blueprints work together and how files should be named. Check out Kieve's excellent Obsidian Cruiser mod.

As for your specific problem, check the buleprint line:

Code: Select all

<shipBlueprint name="PLAYER_SHIP_STEALTH" layout="shipname" img="shipname">

In the img folder, there must be a folder named ship, and inside it the files:
shipname_base.png
shipname_floor.png

Refer to the Obsidian mod for the file structure. Also read this guide. Finally i also suggest you get a copy of KuroSaru's DAT Manager which you can use not only to examine the files inside the database, but you can also remove and replace individual files, save changes and run FTL without using GMM. This can help when making mods as it helps narrow down which file caused an error.

It's highly recommended that you have the original data.dat and resources.dat backed up in case of an emergency. Any more questions, feel free to ask, modding FTL has a steep learning curve. :)
Report spam using the handy Report Button Mod.
robochibi
Posts: 32
Joined: Wed Oct 03, 2012 9:17 pm

Re: [TUTORIAL] Creating Player Ships with FTLEdit

Postby robochibi » Sat Aug 31, 2013 10:04 pm

Been trying endlessly to set this program up. Absolute frustration on trying to get the files to extract! It just blink pops. So I tried some other workaround methods that also do not work. I used Superluminal (which set up like clockwork btw) to extract the dat and resources file. I took all those files and put them in a folder just for DarkFrost. I pointed the editor RIGHT into those folders and still it gives me the message that blueprints.xml was not found EVEN THOUGH I AM LOOKING RIGHT AT IT IN THE EXACT FOLDER IT WAS LOOKING FOR IT. WTF ive been fighting with this thing to setup properly for hours. It just shouldnt be this hard.

Who is online

Users browsing this forum: No registered users and 26 guests