[MOD] Spanish Mod v101 / Mod Español

Distribute and discuss mods that are functional. Moderator - Grognak
UltraMantis
Posts: 2141
Joined: Thu Sep 20, 2012 3:17 pm

Re: [MOD] Spanish Mod v101 / Mod Español

Postby UltraMantis » Wed Sep 04, 2013 2:17 pm

I have tested the mod. Most special characters are working, but there are a few that show up as []. This could be an error in the mod itself, a limitation of FTL's fonts, or a conflict in the resources.

When you uninstall FTL only the original files are uninstalled. Mods, unpacked resources, backups and GMM itself are not deleted. Re-installing FTL without deleting these files may cause conflicts.
Report spam using the handy Report Button Mod.
Venturello
Posts: 13
Joined: Sat Oct 20, 2012 10:54 pm

Re: [MOD] Spanish Mod v101 / Mod Español

Postby Venturello » Thu Sep 05, 2013 11:13 am

Hi Ultra - I didnt use uninstall, I literally erased everything on the folder (not using steam, rather FTL's direct download) and started 'from scratch'.

What else could be different that is causing this not to work on my computer, but work on yours? What version of FTL are you using? Of Python?

I am going to try in my son's computer (but it is a similar environment, Win7 64 bits in English).

Anyone else has any other ideas? Thanks again!!
Vhati
Posts: 792
Joined: Thu Oct 25, 2012 12:01 pm

Re: [MOD] Spanish Mod v101 / Mod Español

Postby Vhati » Thu Sep 05, 2013 7:42 pm

Venturello wrote:
UltraMantis wrote:try Slipstream.

Tried that, didn't work... now its worse (see attached image - with GMM I had one box over accents on this text, with SMM, two).

Grr. I see this with Slipstream. :|

accents01.png

accents02.png
accents03.png



I'll investigate and try to fix it in the next update.
Vhati
Posts: 792
Joined: Thu Oct 25, 2012 12:01 pm

Re: [MOD] Spanish Mod v101 / Mod Español

Postby Vhati » Fri Sep 06, 2013 12:13 am

*groan*
FTL assumes all its XML resources to be in windows-1252 encoding, even on Linux... even when you give it hints that it's supposed to be unicode. Despite some of the vanilla resources claiming to be UTF-8. :x

The mod managers made the sensible assumption that UTF-8 would work and often converted mods to that during patching.
Those two encodings are identical except for accented characters.
And the only mod using accents is this one, so the problem went unnoticed.

Well, it could've been worse... At least the game is consistent, not expecting different things on different platforms... :? I hope.


The upcoming Slipstream 1.2 will convert all xml to windows-1252.
* Modders won't need to do anything different.


That should fix the accents on weapons.
Areas like the Med-bots description will have one mystery square (as UltraMantis put it: this could be an error in the mod itself, a limitation of FTL's fonts, or a conflict in the resources).
Venturello
Posts: 13
Joined: Sat Oct 20, 2012 10:54 pm

Re: [MOD] Spanish Mod v101 / Mod Español

Postby Venturello » Fri Sep 06, 2013 8:24 pm

Hi Vhati - exprogrammer here (havent coded in a decade) but understand very well what enconding is, given this is typical encoding problem I thought there was a good chance of this having to do with it. Now managing a software company, it is typical of US products to have such problems!

Anyway, back to this - THANKS. How much time will it take you to have 1.2 ready?

I would like to pay you back some way - I saw your donation thing is not working. Is there any charity you would like me to donate something if this can make this work? I love giving back in some way to people who do things like this.

Thanks again!
Venturello
Posts: 13
Joined: Sat Oct 20, 2012 10:54 pm

Re: [MOD] Spanish Mod v101 / Mod Español

Postby Venturello » Fri Sep 06, 2013 8:42 pm

BTW on Win7 Spanish, with Slipstream 1.1 it did not work... but with GMM IT worked. My son gonna have a wonderful surprise for him tomorrow morning!
Vhati
Posts: 792
Joined: Thu Oct 25, 2012 12:01 pm

Re: [MOD] Spanish Mod v101 / Mod Español

Postby Vhati » Sat Sep 07, 2013 7:40 pm

Venturello wrote:THANKS. How much time will it take you to have 1.2 ready?

Any day now.
Some new bugs were reported at the last minute, as is usually the case.
This was one of those last minute bugs, in fact. :P

Venturello wrote:I would like to pay you back some way - I saw your donation thing is not working.

PM sent. :)
Vhati
Posts: 792
Joined: Thu Oct 25, 2012 12:01 pm

Re: [MOD] Spanish Mod v101 / Mod Español

Postby Vhati » Tue Sep 10, 2013 8:59 am

.
I solved the mystery box problem.

Six of FTL's ten fonts lacked accented characters, so even with the right encoding, there was nothing to display.

To address this, I have edited each font to add the missing characters.

áéíóú ÁÉÍÓÚ ñÑ üÜ ¿¡ ºª

Load the following mod together with "Spanish Mod" and there should be no mystery boxes, anywhere. 8-)

Edit: Link removed (see a later post)


I've notified tonxabar about including them in the next update of "Spanish Mod".
Last edited by Vhati on Tue Sep 10, 2013 8:18 pm, edited 1 time in total.
tonxabar
Posts: 29
Joined: Fri Jan 04, 2013 4:03 pm

Re: [MOD] Spanish Mod v101 / Mod Español

Postby tonxabar » Tue Sep 10, 2013 11:42 am

Oh?
What's this?
A lot of movement in the forums!

:mrgreen:

Thanks, Vhati! I made the same long time ago to solve this same problem in XP... but with no avail (somewhere in my HD have those modified fonts, growing dust...) :D

Well, I've got no problem to include them in the mod. Hope this help everyone, linux and windows equally.

Best regards for everyone!
Image
Venturello
Posts: 13
Joined: Sat Oct 20, 2012 10:54 pm

Re: [MOD] Spanish Mod v101 / Mod Español

Postby Venturello » Tue Sep 10, 2013 11:44 am

tonxabar, nice to see you coming to the thread! Father of two young kids, who can now play thanks to your translations. Muchas gracias y un saludo desde Suiza!

Who is online

Users browsing this forum: No registered users and 61 guests