Page 76 of 77

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Posted: Sun Jun 07, 2020 11:51 pm
by PointMeAtTheDawn
I'm attempting to change the default names of generated characters in the game.

https://drive.google.com/file/d/1lyxv-V ... sp=sharing is my modfile.

I'm not seeing any change - the default names are still being generated. What am I doing wrong? Thank you!

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Posted: Mon Jun 08, 2020 3:57 am
by RAD-82
PointMeAtTheDawn wrote:I'm attempting to change the default names of generated characters in the game.

*link removed* is my modfile.

I'm not seeing any change - the default names are still being generated. What am I doing wrong? Thank you!

You just zipped your .xml file. You need to put your .xml file into a folder called "data" and zip the data folder.

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Posted: Mon Jun 08, 2020 9:15 am
by PointMeAtTheDawn
Thank you :).

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Posted: Wed Aug 05, 2020 7:45 pm
by Aaaaa
I'm getting this error when I try to load Multiverse with hyperspace or without

Patching failed: java.nio.charset.UnmappableCharacterException: Input length = 1

help

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Posted: Wed Aug 05, 2020 8:15 pm
by TheMultiverseTeam
Make sure you've downgraded FTL properly, hyperspace doesn't work on anything other than FTL 1.6.9, so you'll need to use the downgrader file provided.

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Posted: Sun Oct 25, 2020 1:29 pm
by Augustus Strix
Hi everyone,

I'm currently trying to install the Multiverse mod, however I can't install Hyperspace 5.3 using the latest version of Slipstream Mod Manager (1.9.1).
I have downgraded the FTL version to 1.6.9 as recommanded on Hyperspace's homepage, but when I try to validate the mod with Slipstream I get the following error :

~ This mod doesn't append. It clobbers.
FTL itself can tolerate lots of XML typos and still run. But malformed XML may break tools that do proper parsing, and it hinders the development of new tools.
Slipstream will try to parse XML while patching: first strictly, then failing over to a sloppy parser. The sloppy parser will tolerate similar errors, at the risk of unforseen behavior, so satisfying the strict parser is advised.

Here are some other details about the matter :
- Installation of Hyperspace 5.2 using the same process work perfectly fine.
- I start the game through Slipstream to avoid Steam updates (Steam option : only update game when I launch it).
- I'm under Windows 10.

Could someone please provide some help ? Also, I have hesitated between posting here or in Hyperspace page, I hope it's okay.

Augustus

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Posted: Mon Oct 26, 2020 1:31 pm
by porcu93
For what I've read around v 5.3 has been packaged by mistake as a .rar file instead of a .zip file before renaming it as a .ftl file. Extract the content in a folder and then put said content in a .zip file.

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Posted: Tue Oct 27, 2020 9:52 am
by Augustus Strix
Thank you for your return,

I did what you suggested, by extracting the content of Hyperspace.ftl and archiving it in a .zip file using 7-zip with standard parameters, then changing the .zip extension by .ftl, and the error changed to :

Code: Select all

> fonts.png
~ Extraneous top-level file.
FTL itself can tolerate lots of XML typos and still run. But malformed XML may break tools that do proper parsing, and it hinders the development of new tools.
Slipstream will try to parse XML while patching: first strictly, then failing over to a sloppy parser. The sloppy parser will tolerate similar errors, at the risk of unforseen behavior, so satisfying the strict parser is advised.


Also, if I try to launch the game, I get the following warning message :

Code: Select all

Wrong version of Hyperspace detected. Please check that Hyperspace is installed correctly and you are using the correct version of Hyperspace for all of your mods. You can continue, but mods may function incorrectly.


Whereas Hyperspace is the only mod installed. So, I tried to delete the file fonts.png, and now the validation of the mod by Slipstream return "No problems", but I still get the message above, regarding the wrong version of Hyperspace. Plus, I don't know what is the impact of deleting this file...

Again, thank you for your help,

Augustus

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Posted: Sun Nov 01, 2020 7:20 pm
by TheMultiverseTeam
If you're using Multiverse, there is no need to use hyperspace.ftl with it. Just install hyperspace's dll files and downgrade FTL, then patch Multiverse through slipstream. Using hyperspace.ftl can even cause errors, such as the wrong version error, if patched anyways.

Re: Slipstream Mod Manager v1.9.1 (2018-01-07)

Posted: Mon Nov 02, 2020 9:09 pm
by Augustus Strix
Hi TheMultiverseTeam,

Indeed, there was no need to use hyperspace.ftl, my understanding of the installation of Multiverse was incorrect, and I feel a little bit ashamed of it, as it is clearly stated in the main page of Multiverse...
I have been able to start the game and do some exploration properly, and I must say that I am impressed by the quality of this overhaul, it is truly amazing !

Sorry for the trouble, and thank you so much for the help you provided, as much as for your great work,

Augustus